Moodle Blog

Help! I can’t edit my Moodle topic summary – the edit icon’s stuck

A frequent call for help on the forums of moodle.org I have done it myself – you paste some code like javascript (or even that nasty MS Word code) into a topic summary, save it and discover you can’t then click on the edit icon anymore to go back and make alterations. I did a post earlier this year explaining how you can get into  the edit screen of a label if it’s a label that’s been corrupted – here it is – but the process for a topic summary is slightly different so I made a new screencast below. I stress: I am not a coder and so I don’t know any “correct” way of going about these things, but by trial and error (mainly the latter !) I have worked out how you can access the editing screen of your topic summary even though the pen and the hand icon is completely stuck. Watch the video below – if youtube is banned in your place as it is in mine, I have put step by step instructions underneath.

<object width=”480″ height=”385″><param name=”movie” value=”http://www.youtube.com/v/wjSl3rM0qYo&hl=en_GB&fs=1&color1=0x5d1719&color2=0xcd311b”></param><param name=”allowFullScreen” value=”true”></param><param name=”allowscriptaccess” value=”always”></param><embed src=”http://www.youtube.com/v/wjSl3rM0qYo&hl=en_GB&fs=1&color1=0x5d1719&color2=0xcd311b” type=”application/x-shockwave-flash” allowscriptaccess=”always” allowfullscreen=”true” width=”480″ height=”385″></embed></object>

How to get into a topic summary when the icon is “stuck”:

  • turn on the editing in your course
  • click on the “hand and pen” icon of a topic summary that DOES work
  • Go up to the url at the top of your screen – look at the number at the very end  in the address bar
  • It will probably be something like http://YOURMOODLESITE.com/course/editsection.php?id=12
  • The last number is the topic summary number that you are in at present. Type in different numbers near that one until you get to the topic summary that has been corrupted (don’t worry if you end up in a totally different course – just keep changing the number at the end until you get to your “broken” summary.) If you’re lucky it might only be a digit away. If you are even luckier and you only recently edited (broke!) the summary, its url might still be saved in your address bar.
  • When you get to it, delete everything by clicking on the code view icon, rather than doing it in the WYSIWYG editor. Save changes – and you should then have a working topic summary with an edit icon you can click on.
Dieser Beitrag wurde am Monday, 21. December 2009 um 18:14 Uhr veröffentlicht und wurde unter der Kategorie Moodle abgelegt. Du kannst die Kommentare zu diesen Eintrag durch den RSS-Feed verfolgen. Du hast die Möglichkeit einen Kommentar zu hinterlassen, oder einen Trackback von deinem Weblog zu senden.

«  –  »

11 Comments »

  1. Hello Mary,

    I didn’t know how to unblock a topic summary like that (and I imagine it works for everything that has a “hand and pen” icon) but I do know how to find the URL quickly:

    – right click on the “hand and pen” icon
    – in the drop-down menu, select “Copy link location” in Firefox (and something similar in other browsers)
    – paste it into the address field in your browser

    Comment: Glenys Hanson – 06. February 2010 @ 11:37 am

  2. I was able to view and edit a summary using this tutorial but I still don’t see it once I save it. Is there some reason that all of the other weeks aren’t showing? I’ve checked settings and everything is in order.

    Comment: Amal – 28. February 2011 @ 9:38 pm

  3. I can’t really respond much without seeing inside your Moodle – but perhaps you can ask your question with some screenshots on http://www.moodle.org and I can try to help there?

    Comment: admin – 28. February 2011 @ 9:46 pm

  4. Thanks for this tip. It worked well, though what got stuck was edit icon in the “Label” resource.

    Comment: Evie LAurito – 29. June 2011 @ 3:16 pm

  5. Thanks – perhaps you would have benefitted from this post: http://www.moodleblog.net/?p=112

    Comment: admin – 29. June 2011 @ 5:26 pm

  6. Thanks for your help. I can stop worrying now.

    Comment: vasu – 13. December 2011 @ 6:38 pm

  7. Thanks so much for your help. I came across your blog as soon as I googled my problem at not managing to edit a topic summary. Your instructions solved the prob.

    Comment: Elaine – 30. January 2012 @ 8:32 pm

  8. Thank you– this was perfect. And- you were right– I only needed to change the number by one. Thanks!

    Comment: Laurie – 24. January 2013 @ 1:48 pm

  9. Thank you so much for this help. Fixed my problem quickly and easily. Awesome info.

    Comment: Chrystal Cook – 06. March 2013 @ 4:30 am

  10. Hi Mary,

    I am new to moodle and the edit icons are actually missing from all the topics I created on my front page. I cannot edit them now and I am actually stuck with them. I have tried to locate their address using inspect element in Chrome but with no success. Could this be a setting that I have changed in Site Administration and/or user roles?

    Many thanks
    Andreas

    Comment: Andy Solo – 28. September 2015 @ 4:44 pm

  11. Hello Andy. Try asking on the Moodle.org forums and if you can add a screenshot of your front page that will be helpful too. This blog post is very old now 🙂

    Comment: admin – 28. September 2015 @ 4:53 pm

Leave a comment

Pages

The Blog Posts

Search the blog

Meta

 

WP-Design: Vlad -- Powered by WordPress -- XHTML 1.0